Logo Studenta
Gratis
3 pág.
prova

Vista previa | Página 1 de 1

TEMA 1 
Tipo de dato que hace referencia a valores enteros y reales. 
A- Numéricos 
B- Ordinales 
C- Alfanuméricos 
D- Lógicos 
E- Estadísticos 
 
TEMA 2 
¿Qué es un diagrama de flujo?: 
A- Es la representación gráfica de un algoritmo. 
B- Es un programa gráfico. 
C- Es la representación numérica de un algoritmo. 
D- Es un proceso iterativo, en el que se repite un conjunto de operaciones, y está gobernado por una 
operación condicional. 
E- Es una operación condicional que divide la continuidad del flujo del programa por dos caminos distintos. 
TEMA 3 
Determinar la utilidad del siguiente algoritmo 
Inicio 
 i=2 
 x=10 
 limite=10 
 Mientras (i<=limite) 
 x=0 
 Mientras (x<=10) 
 Imprimir x 
 x = x+1 
 Fin Mientras 
 i = i+1 
 Fin Mientras 
 Fin 
 
A- Imprimir nueve veces la serie de números del 0 al 10. 
B- Imprimir dos veces la serie de números del 1 al 10. 
C- Imprimir el numero 10 diez veces. 
D- Imprimir diez veces la serie de números del 10 al 1. 
E- Imprimir diez veces la serie de números del 1 al 10. 
TEMA 4 
 
Identificar las dos líneas con errores para que el valor final de x =50 
1. Inicio 
2. i=0 
3. x=0 
4. Mientras (i<100) 
5. x=x+2 
6. i=i+1 
7. Fin Mientras 
8. Imprimir x 
9. Fin 
 
A. Las líneas 5 y 6 tienen error. 
B- Las líneas 4 y 6 tienen error. 
C- Las líneas 2 y 4 tienen error. 
D- Las líneas 6 y 7 tienen error 
E- Las líneas 4 y 8 tienen error 
 
 
TEMA 5 
El algoritmo a continuación debe imprimir los números múltiplos de 3 desde el 45 hasta el 35 
. 
 
1. Inicio 
2. C=45 
3. cinco=3 
4. Mientras C > 35 
5. Si C mod cinco = 0 
6. Imprimir C 
7. FinSi 
8. C = C + 1 
9. FinMientras 
10. Fin 
 
A- Hay un error en la línea 8 
B- Hay un error en la línea 4 
C- Hay un error en la línea 5 
D- Hay un error en la línea 2 
E- Hay un error en la línea 3 
 
TEMA 6 
El algoritmo a continuación debe leer un numero natural mayor que cero y determine si es par o impar sin 
utilizar la función ENTERO ni el operador MOD. 
 
1. Inicio 
2. X=0 
3. Leer X 
4. C=X 
5. Mientras X >0 
6. X=X-2 
7. FinMientras 
8. Si X=1 
9. Imprimir “El número es PAR” 
10. SiNo 
11. Imprimir “El número es IMPAR” 
12. FinSi 
13. Fin 
 
A- Hay un error en la línea 8 
B- Hay un error en la línea 5 
C- Hay un error en la línea 6 
D- Hay un error en la línea 4 
E- Hay un error en la línea 3